Placa arduino desligando quando alimento pino digital

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Placa arduino desligando quando alimento pino digital

Mensagem  RSALVINO em Qui 16 Maio - 9:07

Olá,

Tenho uma placa arduino Uno, conectada a um sensor (2 fios) da seguinte forma:

Fio 1 do sensor: ligado no 5V do arduino

Fio 2 do sensor: ligado num resistor (R1) de 10 K (pull-down)

R1: ligado no pino GND e também no pino digital 4.

Até aí funciona tudo perfeitamente, quando aciono o sensor, passo o pino digital 4 para nível 4, fazendo funcionar a lógica de meu programa.

Mantendo o esquema acima, puxei mais um fio do pino 5V do arduino para ligar numa chave (ON/OFF), inseri mais um resistor entre o GND do arduino e o pino digital 7, e liguei na outra perna (-) da chave ON/OFF. O problema é que quando quando eu passo a chave para ON toda a alimentação do arduino é cortada, vcs tem idéia do que pode estar gerando este problema?

Reforçando que o problema só ocorre quando ligo a chave ligada no pino digital 7, o sensor que está ligado no pino digital 4 funciona normalmente quando acionado.

Estou utilizando uma fonte de 9V para alimentação do arduino que também está acoplado à um shield GPRS.

Desde já agradeço!

RSALVINO

Mensagens : 9
Data de inscrição : 17/02/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum